What’s Vulnerable › Vulnerabilities
CVE-2023-40023: Yaklang Plugin's Fuzztag Component Allows Unauthorized Local File Reading
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-200
Description
yaklang is a programming language designed for cybersecurity. The Yak Engine has been found to contain a local file inclusion (LFI) vulnerability. This vulnerability allows attackers to include files from the server's local file system through the web application. When exploited, this can lead to the unintended exposure of sensitive data, potential remote code execution, or other security breaches. Users utilizing versions of the Yak Engine prior to 1.2.4-sp1 are impacted. This vulnerability has been patched in version 1.2.4-sp1. Users are advised to upgrade. users unable to upgrade may avoid exposing vulnerable versions to untrusted input and to closely monitor any unexpected server behavior until they can upgrade.
Affected products
- yaklang: 1.2.0-sp6, 1.2.0-sp7, 1.2.0-sp8, 1.2.1, 1.2.1-sp1, 1.2.1-sp2 (+20)
References
- https://github.com/yaklang/yaklang/pull/295
- https://github.com/yaklang/yaklang/pull/296
- https://github.com/yaklang/yaklang/security/advisories/GHSA-xvhg-w6qc-m3qq
- https://github.com/yaklang/yaklang/pull/295
- https://github.com/yaklang/yaklang/pull/296
- https://github.com/yaklang/yaklang/security/advisories/GHSA-xvhg-w6qc-m3qq
Get alerted when CVE-2023-40023 or the next vulnerability affects your stack