What’s Vulnerable › Vulnerabilities
CVE-2023-40027: Conditionally missing authorization in @keystone-6/core
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-15 · updated 2026-06-17
- Weakness: CWE-862
Description
Keystone is an open source headless CMS for Node.js — built with GraphQL and React. When `ui.isAccessAllowed` is set as `undefined`, the `adminMeta` GraphQL query is publicly accessible (no session required). This is different to the behaviour of the default AdminUI middleware, which by default will only be publicly accessible (no session required) if a `session` strategy is not defined. This vulnerability does not affect developers using the `@keystone-6/auth` package, or any users that have written their own `ui.isAccessAllowed` (that is to say, `isAccessAllowed` is not `undefined`). This vulnerability does affect users who believed that their `session` strategy will, by default, enforce that `adminMeta` is inaccessible by the public in accordance with that strategy; akin to the behaviour of the AdminUI middleware. This vulnerability has been patched in `@keystone-6/core` version `5.5.1`. Users are advised to upgrade. Users unable to upgrade may opt to write their own `isAccessAllowed` functionality to work-around this vulnerability.
Affected products
- keystonejs keystone: before 5.5.1 — fixed in 5.5.1
How to fix
Upgrade to a fixed version: keystonejs keystone 5.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/keystonejs/keystone/commit/650e27e6e9b42abfb94c340c8470faf61f0ff284
- https://github.com/keystonejs/keystone/pull/8771
- https://github.com/keystonejs/keystone/security/advisories/GHSA-9cvc-v7wm-992c
- https://github.com/keystonejs/keystone/commit/650e27e6e9b42abfb94c340c8470faf61f0ff284
- https://github.com/keystonejs/keystone/pull/8771
- https://github.com/keystonejs/keystone/security/advisories/GHSA-9cvc-v7wm-992c
Get alerted when CVE-2023-40027 or the next vulnerability affects your stack