What’s Vulnerable › Vulnerabilities
CVE-2023-40032: Potential segfault due to NULL pointer dereference in libvips
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-11 · updated 2026-06-17
- Weakness: CWE-476
Description
libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
Affected products
- Fedoraproject Fedora: 39
- libvips: from 8.12.0 before 8.14.4 — fixed in 8.14.4
How to fix
Upgrade to a fixed version: libvips 8.14.4. Check the vendor advisory for mitigations.
References
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b
- https://github.com/libvips/libvips/pull/3604
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b
- https://github.com/libvips/libvips/pull/3604
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/
Get alerted when CVE-2023-40032 or the next vulnerability affects your stack