What’s Vulnerable › Vulnerabilities
CVE-2023-40033: Server-Side Request Forgery via Avatar upload in flarum
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-918
Description
Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.
Affected products
- Flarum: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Flarum 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/flarum/framework/commit/d1059c1cc79fe61f9538f3da55e8f42abbede570
- https://github.com/flarum/framework/security/advisories/GHSA-67c6-q4j4-hccg
- https://github.com/flarum/framework/commit/d1059c1cc79fe61f9538f3da55e8f42abbede570
- https://github.com/flarum/framework/security/advisories/GHSA-67c6-q4j4-hccg
Get alerted when CVE-2023-40033 or the next vulnerability affects your stack