What’s Vulnerable › Vulnerabilities
CVE-2023-40034: Repositoty takeover in woodpecker-ci
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Woodpecker is a community fork of the Drone CI system. In affected versions an attacker can post malformed webhook data witch lead to an update of the repository data that can e.g. allow the takeover of an repo. This is only critical if the CI is configured for public usage and connected to a forge witch is also in public usage. This issue has been addressed in version 1.0.2. Users are advised to upgrade. Users unable to upgrade should secure the CI system by making it inaccessible to untrusted entities, for example, by placing it behind a firewall.
Affected products
- woodpecker-ci woodpecker: from 1.0.0 before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: woodpecker-ci woodpecker 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/woodpecker-ci/woodpecker/commit/6e4c2f84cc84661d58cf1c0e5c421a46070bb105
- https://github.com/woodpecker-ci/woodpecker/pull/2221
- https://github.com/woodpecker-ci/woodpecker/pull/2222
- https://github.com/woodpecker-ci/woodpecker/security/advisories/GHSA-4gcf-5m39-98mc
- https://github.com/woodpecker-ci/woodpecker/commit/6e4c2f84cc84661d58cf1c0e5c421a46070bb105
- https://github.com/woodpecker-ci/woodpecker/pull/2221
- https://github.com/woodpecker-ci/woodpecker/pull/2222
- https://github.com/woodpecker-ci/woodpecker/security/advisories/GHSA-4gcf-5m39-98mc
Get alerted when CVE-2023-40034 or the next vulnerability affects your stack