What’s Vulnerable › Vulnerabilities
CVE-2023-40035: Craft CMS vulnerable to Remote Code Execution via validatePath bypass
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-23 · updated 2026-06-17
- Weakness: CWE-74
Description
Craft is a CMS for creating custom digital experiences on the web and beyond. Bypassing the validatePath function can lead to potential remote code execution. This vulnerability can lead to malicious control of vulnerable systems and data exfiltrations. Although the vulnerability is exploitable only in the authenticated users, configuration with ALLOW_ADMIN_CHANGES=true, there is still a potential security threat (Remote Code Execution). This issue has been patched in version 4.4.15 and version 3.8.15.
Affected products
- craftcms cms: from 3.0.0 before 3.8.15; from 4.0.0 before 4.4.15; 4.0.0-rc1 — fixed in 3.8.15, 4.4.15
How to fix
Upgrade to a fixed version: craftcms cms 3.8.15, 4.4.15. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/0bd33861abdc60c93209cff03eeee54504d3d3b5
- https://github.com/craftcms/cms/releases/tag/3.8.15
- https://github.com/craftcms/cms/releases/tag/4.4.15
- https://github.com/craftcms/cms/security/advisories/GHSA-44wr-rmwq-3phw
- https://github.com/craftcms/cms/commit/0bd33861abdc60c93209cff03eeee54504d3d3b5
- https://github.com/craftcms/cms/releases/tag/3.8.15
- https://github.com/craftcms/cms/releases/tag/4.4.15
- https://github.com/craftcms/cms/security/advisories/GHSA-44wr-rmwq-3phw
Get alerted when CVE-2023-40035 or the next vulnerability affects your stack