What’s Vulnerable › Vulnerabilities
CVE-2023-40037: Apache NiFi: Incomplete Validation of JDBC and JNDI Connection URLs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-18 · updated 2026-06-17
- Weakness: CWE-184
Description
Apache NiFi 1.21.0 through 1.23.0 support JDBC and JNDI JMS access in several Processors and Controller Services with connection URL validation that does not provide sufficient protection against crafted inputs. An authenticated and authorized user can bypass connection URL validation using custom input formatting. The resolution enhances connection URL validation and introduces validation for additional related properties. Upgrading to Apache NiFi 1.23.1 is the recommended mitigation.
Affected products
- Apache Software Foundation Apache NiFi: from 1.21.0 before 1.23.1 — fixed in 1.23.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 1.23.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/08/18/2
- https://lists.apache.org/thread/bqbjlrs2p5ghh8sbk5nsxb8xpf9l687q
- https://nifi.apache.org/security.html#CVE-2023-40037
- http://www.openwall.com/lists/oss-security/2023/08/18/2
- https://lists.apache.org/thread/bqbjlrs2p5ghh8sbk5nsxb8xpf9l687q
- https://nifi.apache.org/security.html#CVE-2023-40037
Get alerted when CVE-2023-40037 or the next vulnerability affects your stack