What’s Vulnerable › Vulnerabilities
CVE-2023-40047: WS_FTP Server Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
In WS_FTP Server version prior to 8.8.2, a stored cross-site scripting (XSS) vulnerability exists in WS_FTP Server's Management module. An attacker with administrative privileges could import a SSL certificate with malicious attributes containing cross-site scripting payloads. Once the cross-site scripting payload is successfully stored, an attacker could leverage this vulnerability to target WS_FTP Server admins with a specialized payload which results in the execution of malicious JavaScript within the context of the victims browser.
Affected products
- Progress Software Corporation WS_FTP Server: before 8.8.2 — fixed in 8.8.2
How to fix
Upgrade to a fixed version: Progress Software Corporation WS_FTP Server 8.8.2. Check the vendor advisory for mitigations.
References
- https://community.progress.com/s/article/WS-FTP-Server-Critical-Vulnerability-September-2023
- https://www.progress.com/ws_ftp
- https://community.progress.com/s/article/WS-FTP-Server-Critical-Vulnerability-September-2023
- https://www.progress.com/ws_ftp
Get alerted when CVE-2023-40047 or the next vulnerability affects your stack