What’s Vulnerable › Vulnerabilities
CVE-2023-40178: @node-saml/node-saml's validatePostRequestAsync does not include checkTimestampsValidityError
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-23 · updated 2026-06-17
- Weakness: CWE-347
Description
Node-SAML is a SAML library not dependent on any frameworks that runs in Node. The lack of checking of current timestamp allows a LogoutRequest XML to be reused multiple times even when the current time is past the NotOnOrAfter. This could impact the user where they would be logged out from an expired LogoutRequest. In bigger contexts, if LogoutRequests are sent out in mass to different SPs, this could impact many users on a large scale. This issue was patched in version 4.0.5.
Affected products
- node-saml: before 4.0.5 — fixed in 4.0.5
How to fix
Upgrade to a fixed version: node-saml 4.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/node-saml/node-saml/commit/045e3b9c54211fdb95f96edf363679845b195cec
- https://github.com/node-saml/node-saml/releases/tag/v4.0.5
- https://github.com/node-saml/node-saml/security/advisories/GHSA-vx8m-6fhw-pccw
- https://github.com/node-saml/node-saml/commit/045e3b9c54211fdb95f96edf363679845b195cec
- https://github.com/node-saml/node-saml/releases/tag/v4.0.5
- https://github.com/node-saml/node-saml/security/advisories/GHSA-vx8m-6fhw-pccw
Get alerted when CVE-2023-40178 or the next vulnerability affects your stack