What’s Vulnerable › Vulnerabilities
CVE-2023-40195: Apache Airflow Spark Provider Deserialization Vulnerability RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-28 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Software Foundation Apache Airflow Spark Provider. When the Apache Spark provider is installed on an Airflow deployment, an Airflow user that is authorized to configure Spark hooks can effectively run arbitrary code on the Airflow node by pointing it at a malicious Spark server. Prior to version 4.1.3, this was not called out in the documentation explicitly, so it is possible that administrators provided authorizations to configure Spark hooks without taking this into account. We recommend administrators to review their configurations to make sure the authorization to configure Spark hooks is only provided to fully trusted users. To view the warning in the docs please visit https://airflow.apache.org/docs/apache-airflow-providers-apache-spark/4.1.3/connections/spark.html
Affected products
- Apache Airflow Spark Provider: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Apache Airflow Spark Provider 4.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/33233
- https://lists.apache.org/thread/fzy95b1d6zv31j5wrx3znhzcscck2o24
- https://github.com/apache/airflow/pull/33233
- https://lists.apache.org/thread/fzy95b1d6zv31j5wrx3znhzcscck2o24
Get alerted when CVE-2023-40195 or the next vulnerability affects your stack