What’s Vulnerable › Vulnerabilities
CVE-2023-4022: Herd Effects < 5.2.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-11 · updated 2026-06-17
Description
The Herd Effects WordPress plugin before 5.2.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Herd Effects: before 5.2.3 — fixed in 5.2.3
How to fix
Upgrade to a fixed version: Herd Effects 5.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c4ac0b19-58b1-4620-b3b7-fbe6dd6c8dd5
- https://wpscan.com/vulnerability/c4ac0b19-58b1-4620-b3b7-fbe6dd6c8dd5
Get alerted when CVE-2023-4022 or the next vulnerability affects your stack