What’s Vulnerable › Vulnerabilities

CVE-2023-40225

Description

HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23, 2.5.x and 2.6.x before 2.6.15, 2.7.x before 2.7.10, and 2.8.x before 2.8.2 forwards empty Content-Length headers, violating RFC 9110 section 8.6. In uncommon cases, an HTTP/1 server behind HAProxy may interpret the payload as an extra request.

Affected products

How to fix

Upgrade to a fixed version: HAProxy 2.6.15, 2.7.10, 2.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-40225 or the next vulnerability affects your stack