What’s Vulnerable › Vulnerabilities
CVE-2023-4025: Radio Player <= 2.0.73 - Missing Authorization to Player Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
- Weakness: CWE-862
Description
The Radio Player plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the update_player function in versions up to, and including, 2.0.73. This makes it possible for unauthenticated attackers to update player instances.
Affected products
- princeahmed Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player: before 2.0.74 — fixed in 2.0.74
How to fix
Upgrade to a fixed version: princeahmed Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player 2.0.74. Check the vendor advisory for mitigations.
References
- https://plugins.svn.wordpress.org/radio-player/tags/2.0.7/readme.txt
- https://plugins.trac.wordpress.org/changeset/2942906/radio-player/trunk/includes/class-ajax.php
- https://plugins.trac.wordpress.org/changeset/3048105
- https://www.wordfence.com/threat-intel/vulnerabilities/id/77409977-6822-4d14-9842-cb6a5aff2162?source=cve
Get alerted when CVE-2023-4025 or the next vulnerability affects your stack