What’s Vulnerable › Vulnerabilities
CVE-2023-40272: Apache Airflow Spark Provider Arbitrary File Read via JDBC
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Airflow Spark Provider, versions before 4.1.3, is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection giving an opportunity to read files on the Airflow server. It is recommended to upgrade to a version that is not affected.
Affected products
- Apache Software Foundation Apache Airflow Spark Provider: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Spark Provider 4.1.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/08/17/1
- http://www.openwall.com/lists/oss-security/2023/08/18/1
- https://lists.apache.org/thread/t03gktyzyor20rh06okd91jtqmw6k1l7
- http://www.openwall.com/lists/oss-security/2023/08/17/1
- http://www.openwall.com/lists/oss-security/2023/08/18/1
- https://lists.apache.org/thread/t03gktyzyor20rh06okd91jtqmw6k1l7
Get alerted when CVE-2023-40272 or the next vulnerability affects your stack