What’s Vulnerable › Vulnerabilities
CVE-2023-40281
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-17 · updated 2026-06-17
- Weakness: CWE-79
Description
EC-CUBE 2.11.0 to 2.17.2-p1 contain a cross-site scripting vulnerability in "mail/template" and "products/product" of Management page. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the other administrator or the user who accessed the website using the product.
Affected products
- EC-CUBE CO.,LTD. EC-CUBE: from 2.11.0 through 2.11.5; from 2.12.0 through 2.12.6; from 2.13.0 before 2.13.5; from 2.17.0 before 2.17.2; 2.13.5, 2.13.5-patch1, 2.17.2, 2.17.2-patch1 — fixed in 2.13.5, 2.17.2
How to fix
Upgrade to a fixed version: EC-CUBE CO.,LTD. EC-CUBE 2.13.5, 2.17.2. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN46993816/
- https://www.ec-cube.net/info/weakness/20230727/
- https://jvn.jp/en/jp/JVN46993816/
- https://www.ec-cube.net/info/weakness/20230727/
Get alerted when CVE-2023-40281 or the next vulnerability affects your stack