What’s Vulnerable › Vulnerabilities
CVE-2023-40283
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-10-15
- Weakness: CWE-416
Description
An issue was discovered in l2cap_sock_release in net/bluetooth/l2cap_sock.c in the Linux kernel before 6.4.10. There is a use-after-free because the children of an sk are mishandled.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 22.04
- Debian Linux: 10.0, 11.0, 12.0
- Linux kernel: from 3.5 before 4.14.322; from 4.15 before 4.19.291; from 4.20 before 5.4.253; from 5.5 before 5.10.190; from 5.11 before 5.15.126; from 5.16 before 6.1.45 — fixed in 4.14.322, 4.19.291, 5.10.190, 5.15.126, 5.4.253, 6.1.45
How to fix
Upgrade to a fixed version: Linux kernel 4.14.322, 4.19.291, 5.10.190, 5.15.126. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/175072/Kernel-Live-Patch-Security-Notice-LSN-0098-1.html
- http://packetstormsecurity.com/files/175963/Kernel-Live-Patch-Security-Notice-LSN-0099-1.html
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.4.10
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1728137b33c00d5a2b5110ed7aafb42e7c32e4a1
- https://github.com/torvalds/linux/commit/1728137b33c00d5a2b5110ed7aafb42e7c32e4a1
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://security.netapp.com/advisory/ntap-20231020-0007/
- https://www.debian.org/security/2023/dsa-5480
- https://www.debian.org/security/2023/dsa-5492
- http://packetstormsecurity.com/files/175072/Kernel-Live-Patch-Security-Notice-LSN-0098-1.html
- http://packetstormsecurity.com/files/175963/Kernel-Live-Patch-Security-Notice-LSN-0099-1.html
Get alerted when CVE-2023-40283 or the next vulnerability affects your stack