What’s Vulnerable › Vulnerabilities
CVE-2023-40307: Privileges Memory Corruption (Out-of-bound write)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-28 · updated 2026-06-17
- Weakness: CWE-787
Description
An attacker with standard privileges on macOS when requesting administrator privileges from the application can submit input which causes a buffer overflow resulting in a crash of the application. This could make the application unavailable and allow reading or modification of data.
Affected products
- SAP Privileges: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: SAP Privileges 1.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/SAP/macOS-enterprise-privileges/security/advisories/GHSA-rgq4-wxpj-5jv9
- https://github.com/SAP/macOS-enterprise-privileges/security/advisories/GHSA-rgq4-wxpj-5jv9
Get alerted when CVE-2023-40307 or the next vulnerability affects your stack