What’s Vulnerable › Vulnerabilities
CVE-2023-40311: Stored XSS in multiple JSP files in opennms/opennms
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
Affected products
- The OpenNMS Group Horizon: from 31.0.8 before 32.0.2 — fixed in 32.0.2
- The OpenNMS Group Meridian: before 2020.1.38; from 2022.1.0 before 2022.1.19; from 2023.1.0 before 2023.1.6 — fixed in 2020.1.38, 2022.1.19, 2023.1.6
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 32.0.2; The OpenNMS Group Meridian 2020.1.38, 2022.1.19, 2023.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/OpenNMS/opennms
- https://github.com/OpenNMS/opennms/pull/6365
- https://github.com/OpenNMS/opennms/pull/6366
- https://github.com/OpenNMS/opennms
- https://github.com/OpenNMS/opennms/pull/6365
- https://github.com/OpenNMS/opennms/pull/6366
Get alerted when CVE-2023-40311 or the next vulnerability affects your stack