What’s Vulnerable › Vulnerabilities
CVE-2023-40313: Disable BeanShell Interpreter Remote Server Mode
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-17 · updated 2026-06-17
- Weakness: CWE-94
Description
A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected products
- The OpenNMS Group Horizon: before 32.0.2 — fixed in 32.0.2
- The OpenNMS Group Meridian: before 2020.1.38; from 2021.1.0 before 2021.1.30; from 2022.1.0 before 2022.1.19; from 2023.1.0 before 2023.1.6 — fixed in 2020.1.38, 2021.1.30, 2022.1.19, 2023.1.6
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 32.0.2; The OpenNMS Group Meridian 2020.1.38, 2021.1.30, 2022.1.19, 2023.1.6. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/horizon/32/releasenotes/changelog.html
- https://github.com/OpenNMS/opennms/pull/6368
- https://docs.opennms.com/horizon/32/releasenotes/changelog.html
- https://github.com/OpenNMS/opennms/pull/6368
Get alerted when CVE-2023-40313 or the next vulnerability affects your stack