What’s Vulnerable › Vulnerabilities
CVE-2023-40314: Cross-site scripting in bootstrap.jsp
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.
Affected products
- The OpenNMS Group Horizon: before 32.0.5 — fixed in 32.0.5
- The OpenNMS Group Meridian: before 2023.1.9 — fixed in 2023.1.9
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 32.0.5; The OpenNMS Group Meridian 2023.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-40314 or the next vulnerability affects your stack