What’s Vulnerable › Vulnerabilities
CVE-2023-40315: ROLE_FILESYSTEM_EDITOR Can Be Used To Escalate To ROLE_ADMIN
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-17 · updated 2026-06-17
- Weakness: CWE-863
Description
In OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Affected products
- The OpenNMS Group Horizon: from 31.0.8 before 32.0.2 — fixed in 32.0.2
- The OpenNMS Group Meridian: from 2023.0.0 before 2023.1.5 — fixed in 2023.1.5
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 32.0.2; The OpenNMS Group Meridian 2023.1.5. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.5
- https://github.com/OpenNMS/opennms/pull/6250
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.5
- https://github.com/OpenNMS/opennms/pull/6250
Get alerted when CVE-2023-40315 or the next vulnerability affects your stack