What’s Vulnerable › Vulnerabilities
CVE-2023-40356: PingOne MFA Integration Kit MFA bypass
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-290
Description
PingOne MFA Integration Kit contains a vulnerability related to the Prompt Users to Set Up MFA configuration. Under certain conditions, this configuration could allow for a new MFA device to be paired with a target user account without requiring second-factor authentication from the target’s existing registered devices. A threat actor might be able to exploit this vulnerability to register their own MFA device with a target user’s account if they have existing knowledge of the target user’s first factor credential.
Affected products
- Pingone Mfa Intergration Kit For Pingfederate: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: Pingone Mfa Intergration Kit For Pingfederate 2.3.1. Check the vendor advisory for mitigations.
References
- https://docs.pingidentity.com/r/en-us/pingfederate-pingone-mfa-ik/bks1657303194394
- https://docs.pingidentity.com/r/en-us/pingfederate-pingone-mfa-ik/bks1657303194394
Get alerted when CVE-2023-40356 or the next vulnerability affects your stack