What’s Vulnerable › Vulnerabilities
CVE-2023-40397
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
Description
The issue was addressed with improved checks. This issue is fixed in macOS Ventura 13.5. A remote attacker may be able to cause arbitrary javascript code execution.
Affected products
- Apple macOS: before 13.5 — fixed in 13.5
- Webkit: before 2.40.5 — fixed in 2.40.5
- Wpewebkit Wpe Webkit: before 2.40.5 — fixed in 2.40.5
How to fix
Upgrade to a fixed version: Apple macOS 13.5; Webkit 2.40.5; Wpewebkit Wpe Webkit 2.40.5. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/09/11/1
- https://security.gentoo.org/glsa/202401-04
- https://support.apple.com/en-us/HT213843
- http://www.openwall.com/lists/oss-security/2023/09/11/1
- https://security.gentoo.org/glsa/202401-04
- https://support.apple.com/en-us/HT213843
Get alerted when CVE-2023-40397 or the next vulnerability affects your stack