What’s Vulnerable › Vulnerabilities
CVE-2023-4040
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-18 · updated 2026-06-17
Description
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the eh_callback_handler function in versions up to, and including, 3.7.9. This makes it possible for unauthenticated attackers to modify the order status of arbitrary WooCommerce orders.
Affected products
- themehigh Payment Gateway of Stripe for WooCommerce: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: themehigh Payment Gateway of Stripe for WooCommerce 3.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2954934/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ef543c61-2acc-4b72-81ff-883960d4c7c3?source=cve
- https://plugins.trac.wordpress.org/changeset/2954934/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ef543c61-2acc-4b72-81ff-883960d4c7c3?source=cve
Get alerted when CVE-2023-4040 or the next vulnerability affects your stack