What’s Vulnerable › Vulnerabilities
CVE-2023-40407
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
Description
The issue was addressed with improved bounds checks. This issue is fixed in macOS Sonoma 14. A remote attacker may be able to cause a denial-of-service.
Affected products
- Apple macOS: before 14.0 — fixed in 14.0
How to fix
Upgrade to a fixed version: Apple macOS 14.0. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/3
- https://support.apple.com/en-us/HT213940
- http://seclists.org/fulldisclosure/2023/Oct/3
- https://support.apple.com/en-us/HT213940
- https://support.apple.com/kb/HT213940
Get alerted when CVE-2023-40407 or the next vulnerability affects your stack