What’s Vulnerable › Vulnerabilities
CVE-2023-40518
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
Description
LiteSpeed OpenLiteSpeed before 1.7.18 does not strictly validate HTTP request headers.
Affected products
- LiteSpeed Technologies OpenLiteSpeed: before 1.7.18 — fixed in 1.7.18
How to fix
Upgrade to a fixed version: LiteSpeed Technologies OpenLiteSpeed 1.7.18. Check the vendor advisory for mitigations.
References
- https://openlitespeed.org/release-log/version-1-7-x/
- https://www.litespeedtech.com/products/litespeed-web-server/release-log
- https://openlitespeed.org/release-log/version-1-7-x/
- https://www.litespeedtech.com/products/litespeed-web-server/release-log
Get alerted when CVE-2023-40518 or the next vulnerability affects your stack