What’s Vulnerable › Vulnerabilities
CVE-2023-40579: OpenFGA Authorization Bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-25 · updated 2026-06-17
- Weakness: CWE-284
Description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.
Affected products
- openfga: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: openfga 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/releases/tag/v1.3.1
- https://github.com/openfga/openfga/security/advisories/GHSA-jcf2-mxr2-gmqp
- https://github.com/openfga/openfga/releases/tag/v1.3.1
- https://github.com/openfga/openfga/security/advisories/GHSA-jcf2-mxr2-gmqp
Get alerted when CVE-2023-40579 or the next vulnerability affects your stack