What’s Vulnerable › Vulnerabilities
CVE-2023-40591: Denial of service via malicious p2p message in go-ethereum
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-400
Description
go-ethereum (geth) is a golang execution layer implementation of the Ethereum protocol. A vulnerable node, can be made to consume unbounded amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix is included in geth version `1.12.1-stable`, i.e, `1.12.2-unstable` and onwards. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- ethereum go-ethereum: from 1.10.0 before 1.12.1 — fixed in 1.12.1
How to fix
Upgrade to a fixed version: ethereum go-ethereum 1.12.1. Check the vendor advisory for mitigations.
References
- https://geth.ethereum.org/docs/developers/geth-developer/disclosures
- https://github.com/ethereum/go-ethereum/releases/tag/v1.12.1
- https://github.com/ethereum/go-ethereum/security/advisories/GHSA-ppjg-v974-84cm
- https://geth.ethereum.org/docs/developers/geth-developer/disclosures
- https://github.com/ethereum/go-ethereum/releases/tag/v1.12.1
- https://github.com/ethereum/go-ethereum/security/advisories/GHSA-ppjg-v974-84cm
Get alerted when CVE-2023-40591 or the next vulnerability affects your stack