What’s Vulnerable › Vulnerabilities
CVE-2023-40610: Apache Superset: Privilege escalation with default examples database
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.
Affected products
- Apache Superset: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Apache Superset 2.1.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/27/2
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-f678-j579-4xf5
- https://lists.apache.org/thread/jvgxpk4dbxyqtsgtl4pdgbd520rc0rot
- http://www.openwall.com/lists/oss-security/2023/11/27/2
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-f678-j579-4xf5
- https://lists.apache.org/thread/jvgxpk4dbxyqtsgtl4pdgbd520rc0rot
Get alerted when CVE-2023-40610 or the next vulnerability affects your stack