What’s Vulnerable › Vulnerabilities
CVE-2023-40611: Apache Airflow Dag Runs Broken Access Control Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc. Users should upgrade to version 2.7.1 or later which has removed the vulnerability.
Affected products
- Apache Airflow: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.7.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/12/1
- https://github.com/apache/airflow/pull/33413
- https://lists.apache.org/thread/8y9xk1s3j4qr36yzqn8ogbn9fl7pxrn0
- http://www.openwall.com/lists/oss-security/2023/11/12/1
- https://github.com/apache/airflow/pull/33413
- https://lists.apache.org/thread/8y9xk1s3j4qr36yzqn8ogbn9fl7pxrn0
Get alerted when CVE-2023-40611 or the next vulnerability affects your stack