What’s Vulnerable › Vulnerabilities
CVE-2023-40711
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-20 · updated 2026-06-17
- Weakness: CWE-787
Description
Veilid before 0.1.9 does not check the size of uncompressed data during decompression upon an envelope receipt, which allows remote attackers to cause a denial of service (out-of-memory abort) via crafted packet data, as exploited in the wild in August 2023.
Affected products
- Veilid: before 0.1.9 — fixed in 0.1.9
How to fix
Upgrade to a fixed version: Veilid 0.1.9. Check the vendor advisory for mitigations.
References
- https://gitlab.com/veilid/veilid/-/blob/main/CHANGELOG.md
- https://gitlab.com/veilid/veilid/-/blob/main/CHANGELOG.md
Get alerted when CVE-2023-40711 or the next vulnerability affects your stack