What’s Vulnerable › Vulnerabilities
CVE-2023-4104
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-11 · updated 2026-06-17
- Weakness: CWE-862
Description
An invalid Polkit Authentication check and missing authentication requirements for D-Bus methods allowed any local user to configure arbitrary VPN setups. *This bug only affects Mozilla VPN on Linux. Other operating systems are unaffected.* This vulnerability affects Mozilla VPN 2.16.1 < (Linux).
Affected products
- Mozilla VPN 2.16.1: before 2.16.1 — fixed in 2.16.1
How to fix
Upgrade to a fixed version: Mozilla VPN 2.16.1 2.16.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1831318
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7055
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7110
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7151
- https://www.mozilla.org/security/advisories/mfsa2023-39/
- https://www.openwall.com/lists/oss-security/2023/08/03/1
- https://bugzilla.mozilla.org/show_bug.cgi?id=1831318
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7055
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7110
- https://github.com/mozilla-mobile/mozilla-vpn-client/pull/7151
- https://www.mozilla.org/security/advisories/mfsa2023-39/
- https://www.openwall.com/lists/oss-security/2023/08/03/1
Get alerted when CVE-2023-4104 or the next vulnerability affects your stack