What’s Vulnerable › Vulnerabilities
CVE-2023-41042: Discourse DoS via remote theme assets
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, importing a remote theme loads their assets into memory without enforcing limits for file size or number of files. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.1.1; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+207) — fixed in 3.1.1
How to fix
Upgrade to a fixed version: discourse 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-2fq5-x3mm-v254
- https://github.com/discourse/discourse/security/advisories/GHSA-2fq5-x3mm-v254
Get alerted when CVE-2023-41042 or the next vulnerability affects your stack