What’s Vulnerable › Vulnerabilities
CVE-2023-41047: Improper Neutralization of Special Elements Used in a Template Engine in OctoPrint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-1336
Description
OctoPrint is a web interface for 3D printers. OctoPrint versions up until and including 1.9.2 contain a vulnerability that allows malicious admins to configure a specially crafted GCODE script that will allow code execution during rendering of that script. An attacker might use this to extract data managed by OctoPrint, or manipulate data managed by OctoPrint, as well as execute arbitrary commands with the rights of the OctoPrint process on the server system. OctoPrint versions from 1.9.3 onward have been patched. Administrators of OctoPrint instances are advised to make sure they can trust all other administrators on their instance and to also not blindly configure arbitrary GCODE scripts found online or provided to them by third parties.
Affected products
- OctoPrint: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: OctoPrint 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/OctoPrint/OctoPrint/commit/d0072cff894509c77e243d6562245ad3079e17db
- https://github.com/OctoPrint/OctoPrint/releases/tag/1.9.3
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-fwfg-vprh-97ph
- https://github.com/OctoPrint/OctoPrint/commit/d0072cff894509c77e243d6562245ad3079e17db
- https://github.com/OctoPrint/OctoPrint/releases/tag/1.9.3
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-fwfg-vprh-97ph
Get alerted when CVE-2023-41047 or the next vulnerability affects your stack