What’s Vulnerable › Vulnerabilities
CVE-2023-41050: Information disclosure through Python's "format" functionality in Zope AccessControl
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-200
Description
AccessControl provides a general security framework for use in Zope. Python's "format" functionality allows someone controlling the format string to "read" objects accessible (recursively) via attribute access and subscription from accessible objects. Those attribute accesses and subscriptions use Python's full blown `getattr` and `getitem`, not the policy restricted `AccessControl` variants `_getattr_` and `_getitem_`. This can lead to critical information disclosure. `AccessControl` already provides a safe variant for `str.format` and denies access to `string.Formatter`. However, `str.format_map` is still unsafe. Affected are all users who allow untrusted users to create `AccessControl` controlled Python code and execute it. A fix has been introduced in versions 4.4, 5.8 and 6.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- zopefoundation AccessControl: before 4.4; from 5.0 before 5.8; from 6.0 before 6.2 — fixed in 4.4, 5.8, 6.2
- zopefoundation Zope: before 4.8.9; from 5.0 before 5.8.4 — fixed in 4.8.9, 5.8.4
How to fix
Upgrade to a fixed version: zopefoundation AccessControl 4.4, 5.8, 6.2; zopefoundation Zope 4.8.9, 5.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/zopefoundation/AccessControl/commit/6bc32692e0d4b8d5cf64eae3d19de987c7375bc9
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-8xv7-89vj-q48c
- https://github.com/zopefoundation/AccessControl/commit/6bc32692e0d4b8d5cf64eae3d19de987c7375bc9
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-8xv7-89vj-q48c
Get alerted when CVE-2023-41050 or the next vulnerability affects your stack