What’s Vulnerable › Vulnerabilities
CVE-2023-41053: Redis SORT_RO may bypass ACL configuration
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-269
Description
Redis is an in-memory database that persists on disk. Redis does not correctly identify keys accessed by `SORT_RO` and as a result may grant users executing this command access to keys that are not explicitly authorized by the ACL configuration. The problem exists in Redis 7.0 or newer and has been fixed in Redis 7.0.13 and 7.2.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Redis: from 7.0 before 7.0.13; 7.2.0, 7.2.0-rc1, 7.2.0-rc2, 7.2.0-rc3 — fixed in 7.0.13
How to fix
Upgrade to a fixed version: Redis 7.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/9e505e6cd842338424e05883521ca1fb7d0f47f6
- https://github.com/redis/redis/security/advisories/GHSA-q4jr-5p56-4xwc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OLBPIUUD273UGRN2WAYHPVUAULY36QVL/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UA4MSJ623BH6HP5UHSJD2FOTN3QM5DQS/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YLYNYT52EHR63E7L7SHRTHEPUMAFFDLX/
- https://github.com/redis/redis/commit/9e505e6cd842338424e05883521ca1fb7d0f47f6
- https://github.com/redis/redis/security/advisories/GHSA-q4jr-5p56-4xwc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OLBPIUUD273UGRN2WAYHPVUAULY36QVL/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UA4MSJ623BH6HP5UHSJD2FOTN3QM5DQS/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YLYNYT52EHR63E7L7SHRTHEPUMAFFDLX/
Get alerted when CVE-2023-41053 or the next vulnerability affects your stack