What’s Vulnerable › Vulnerabilities
CVE-2023-41057: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-04 · updated 2026-06-17
- Weakness: CWE-22
Description
hyper-bump-it is a command line tool for updating the version in project files.`hyper-bump-it` reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project. The default behaviour of `hyper-bump-it` is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt. This issue has been fixed in release version 0.5.1. Users are advised to upgrade. Users that are unable to update from vulnerable versions, executing `hyper-bump-it` with the `--interactive` command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains `show_confirm_prompt=true`.
Affected products
- plannigan hyper-bump-it: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: plannigan hyper-bump-it 0.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/plannigan/hyper-bump-it/pull/307
- https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448
- https://github.com/plannigan/hyper-bump-it/pull/307
- https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448
Get alerted when CVE-2023-41057 or the next vulnerability affects your stack