What’s Vulnerable › Vulnerabilities
CVE-2023-4107: Incorrect authorization allows a user manager to update a system admin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-863
Description
Mattermost fails to properly validate the requesting user permissions when updating a system admin, allowing a user manager to update a system admin's details such as email, first name and last name.
Affected products
- Mattermost App Framework: from 7.8.0 before 7.8.8; from 7.9.0 before 7.9.6; from 7.10.0 before 7.10.4 — fixed in 7.10.4, 7.8.8, 7.9.6
How to fix
Upgrade to a fixed version: Mattermost App Framework 7.10.4, 7.8.8, 7.9.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-4107 or the next vulnerability affects your stack