What’s Vulnerable › Vulnerabilities
CVE-2023-41081: Apache Tomcat Connectors: Unexpected use of first declared worker in mod_jk for unmapped request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
Description
Important: Authentication Bypass CVE-2023-41081 The mod_jk component of Apache Tomcat Connectors in some circumstances, such as when a configuration included "JkOptions +ForwardDirectories" but the configuration did not provide explicit mounts for all possible proxied requests, mod_jk would use an implicit mapping and map the request to the first defined worker. Such an implicit mapping could result in the unintended exposure of the status worker and/or bypass security constraints configured in httpd. As of JK 1.2.49, the implicit mapping functionality has been removed and all mappings must now be via explicit configuration. Only mod_jk is affected by this issue. The ISAPI redirector is not affected. This issue affects Apache Tomcat Connectors (mod_jk only): from 1.2.0 through 1.2.48. Users are recommended to upgrade to version 1.2.49, which fixes the issue. History 2023-09-13 Original advisory 2023-09-28 Updated summary
Affected products
- Apache Tomcat Connectors: from 1.2.0 before 1.2.49 — fixed in 1.2.49
How to fix
Upgrade to a fixed version: Apache Tomcat Connectors 1.2.49. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/09/28/7
- https://lists.apache.org/thread/rd1r26w7271jyqgzr4492tooyt583d8b
- https://lists.debian.org/debian-lts-announce/2023/09/msg00027.html
- https://www.openwall.com/lists/oss-security/2023/09/13/2
- http://www.openwall.com/lists/oss-security/2023/09/28/7
- https://lists.apache.org/thread/rd1r26w7271jyqgzr4492tooyt583d8b
- https://lists.debian.org/debian-lts-announce/2023/09/msg00027.html
- https://www.openwall.com/lists/oss-security/2023/09/13/2
Get alerted when CVE-2023-41081 or the next vulnerability affects your stack