What’s Vulnerable › Vulnerabilities
CVE-2023-41104
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-23 · updated 2026-06-17
- Weakness: CWE-119
Description
libvmod-digest before 1.0.3, as used in Varnish Enterprise 6.0.x before 6.0.11r5, has an out-of-bounds memory access during base64 decoding, leading to both authentication bypass and information disclosure; however, the exact attack surface will depend on the particular VCL (Varnish Configuration Language) configuration in use.
Affected products
- varnish-software Varnish Enterprise: from 6.0.0 before 6.0.11; 6.0.11, 6.0.11-r1, 6.0.11-r2, 6.0.11-r3, 6.0.11-r4 — fixed in 6.0.11
- varnish-software Vmod Digest: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: varnish-software Varnish Enterprise 6.0.11; varnish-software Vmod Digest 1.0.3. Check the vendor advisory for mitigations.
References
- https://docs.varnish-software.com/security/VSV00012/
- https://github.com/varnish/libvmod-digest/releases/tag/libvmod-digest-1.0.3
- https://www.varnish-cache.org/security/VSV00012.html
- https://docs.varnish-software.com/security/VSV00012/
- https://github.com/varnish/libvmod-digest/releases/tag/libvmod-digest-1.0.3
- https://www.varnish-cache.org/security/VSV00012.html
Get alerted when CVE-2023-41104 or the next vulnerability affects your stack