What’s Vulnerable › Vulnerabilities

CVE-2023-41164: Django Denial of service vulnerability in django.utils.encoding.uri_to_iri

Description

In Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.

Affected products

How to fix

Upgrade to a fixed version: Django 3.2.21, 4.1.11, 4.2.5; Pypi Django 3.2.21, 4.1.11, 4.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-41164 or the next vulnerability affects your stack