What’s Vulnerable › Vulnerabilities
CVE-2023-41289: QcalAgent
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-05 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability has been reported to affect QcalAgent. If exploited, the vulnerability could allow authenticated users to execute commands via a network. We have already fixed the vulnerability in the following version: QcalAgent 1.1.8 and later
Affected products
- QNAP Systems Inc. QcalAgent: from 1.1.0 before 1.1.8 — fixed in 1.1.8
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QcalAgent 1.1.8. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-34
- https://www.qnap.com/en/security-advisory/qsa-23-34
Get alerted when CVE-2023-41289 or the next vulnerability affects your stack