What’s Vulnerable › Vulnerabilities
CVE-2023-4130: ksmbd: fix wrong next length validation of ea buffer in smb2_set_ea()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-08-15
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix wrong next length validation of ea buffer in smb2_set_ea() There are multiple smb2_ea_info buffers in FILE_FULL_EA_INFORMATION request from client. ksmbd find next smb2_ea_info using ->NextEntryOffset of current smb2_ea_info. ksmbd need to validate buffer length Before accessing the next ea. ksmbd should check buffer length using buf_len, not next variable. next is the start offset of current ea that got from previous ea.
Affected products
- Linux kernel: from 5.15 before 5.15.127; from 5.16 before 6.1.46; from 6.2 before 6.4.11; 6.5-rc1, 6.5-rc2, 6.5-rc3, 6.5-rc4, 6.5-rc5 — fixed in 5.15.127, 6.1.46, 6.4.11
How to fix
Upgrade to a fixed version: Linux kernel 5.15.127, 6.1.46, 6.4.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4bf629262f9118ee91b1c3a518ebf2b3bcb22180
- https://git.kernel.org/stable/c/79ed288cef201f1f212dfb934bcaac75572fb8f6
- https://git.kernel.org/stable/c/aeb974907642be095e38ecb1a400ca583958b2b0
- https://git.kernel.org/stable/c/f339d76a3a972601d0738b881b099d49ebbdc3a2
Get alerted when CVE-2023-4130 or the next vulnerability affects your stack