What’s Vulnerable › Vulnerabilities
CVE-2023-41316: HTML Injection with email in Tolgee
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Tolgee is an open-source localization platform. Due to lack of validation field - Org Name, bad actor can send emails with HTML injected code to the victims. Registered users can inject HTML into unsanitized emails from the Tolgee instance to other users. This unsanitized HTML ends up in invitation emails which appear as legitimate org invitations. Bad actors may direct users to malicious website or execute javascript in the context of the users browser. This vulnerability has been addressed in version 3.29.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- tolgee-platform: before 3.29.2 — fixed in 3.29.2
How to fix
Upgrade to a fixed version: tolgee-platform 3.29.2. Check the vendor advisory for mitigations.
References
- https://github.com/tolgee/tolgee-platform/commit/bab718b1c9b3e90327bfb10d27b9799996e5c35b
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-gx3w-rwh5-w5cg
- https://github.com/tolgee/tolgee-platform/commit/bab718b1c9b3e90327bfb10d27b9799996e5c35b
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-gx3w-rwh5-w5cg
Get alerted when CVE-2023-41316 or the next vulnerability affects your stack