What’s Vulnerable › Vulnerabilities
CVE-2023-41328: Possibility limited SQL injection due to insufficient validation in Frappe
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-89
Description
Frappe is a low code web framework written in Python and Javascript. A SQL Injection vulnerability has been identified in the Frappe Framework which could allow a malicious actor to access sensitive information. This issue has been addressed in versions 13.46.1 and 14.20.0. Users are advised to upgrade. There's no workaround to fix this without upgrading.
Affected products
- frappe: before 13.46.1; from 14.0.0 before 14.20.0 — fixed in 13.46.1, 14.20.0
How to fix
Upgrade to a fixed version: frappe 13.46.1, 14.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/releases/tag/v13.46.1
- https://github.com/frappe/frappe/releases/tag/v14.20.0
- https://github.com/frappe/frappe/security/advisories/GHSA-53wh-f67g-9679
- https://github.com/frappe/frappe/releases/tag/v13.46.1
- https://github.com/frappe/frappe/releases/tag/v14.20.0
- https://github.com/frappe/frappe/security/advisories/GHSA-53wh-f67g-9679
Get alerted when CVE-2023-41328 or the next vulnerability affects your stack