What’s Vulnerable › Vulnerabilities
CVE-2023-41332: Denial of service via Kubernetes annotations in specific Cilium configurations
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-755
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with `policy.cilium.io/proxy-visibility` annotations (in Cilium >= v1.13) or `io.cilium.proxy-visibility` annotations (in Cilium <= v1.12) causes the Cilium agent to segfault on the node to which the workload is assigned. Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks. This issue has been resolved in Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users unable to upgrade can avoid this denial of service attack by enabling the Layer 7 proxy.
Affected products
- cilium: before 1.12.14; from 1.13.0 before 1.13.7; from 1.14.0 before 1.14.2 — fixed in 1.12.14, 1.13.7, 1.14.2
How to fix
Upgrade to a fixed version: cilium 1.12.14, 1.13.7, 1.14.2. Check the vendor advisory for mitigations.
References
- https://github.com/cilium/cilium/pull/27597
- https://github.com/cilium/cilium/security/advisories/GHSA-24m5-r6hv-ccgp
- https://github.com/cilium/cilium/pull/27597
- https://github.com/cilium/cilium/security/advisories/GHSA-24m5-r6hv-ccgp
Get alerted when CVE-2023-41332 or the next vulnerability affects your stack