What’s Vulnerable › Vulnerabilities
CVE-2023-41333: Bypass of namespace restrictions in CiliumNetworkPolicy
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-306
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An attacker with the ability to create or modify CiliumNetworkPolicy objects in a particular namespace is able to affect traffic on an entire Cilium cluster, potentially bypassing policy enforcement in other namespaces. By using a crafted `endpointSelector` that uses the `DoesNotExist` operator on the `reserved:init` label, the attacker can create policies that bypass namespace restrictions and affect the entire Cilium cluster. This includes potentially allowing or denying all traffic. This attack requires API server access, as described in the Kubernetes API Server Attacker section of the Cilium Threat Model. This issue has been resolved in Cilium versions 1.14.2, 1.13.7, and 1.12.14. As a workaround an admission webhook can be used to prevent the use of `endpointSelectors` that use the `DoesNotExist` operator on the `reserved:init` label in CiliumNetworkPolicies.
Affected products
- cilium: before 1.12.14; from 1.13.0 before 1.13.7; from 1.14.0 before 1.14.2 — fixed in 1.12.14, 1.13.7, 1.14.2
How to fix
Upgrade to a fixed version: cilium 1.12.14, 1.13.7, 1.14.2. Check the vendor advisory for mitigations.
References
- https://docs.cilium.io/en/stable/security/threat-model/#kubernetes-api-server-attacker
- https://github.com/cilium/cilium/pull/28007
- https://github.com/cilium/cilium/security/advisories/GHSA-4xp2-w642-7mcx
- https://docs.cilium.io/en/stable/security/threat-model/#kubernetes-api-server-attacker
- https://github.com/cilium/cilium/pull/28007
- https://github.com/cilium/cilium/security/advisories/GHSA-4xp2-w642-7mcx
Get alerted when CVE-2023-41333 or the next vulnerability affects your stack