What’s Vulnerable › Vulnerabilities
CVE-2023-41336: Prevent injection of invalid entity ids for "autocomplete" fields in symfony ux-autocomplete
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-11 · updated 2026-06-17
- Weakness: CWE-20
Description
ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.
Affected products
- symfony ux-autocomplete: before 2.11.2 — fixed in 2.11.2
How to fix
Upgrade to a fixed version: symfony ux-autocomplete 2.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/ux-autocomplete/CVE-2023-41336.yaml
- https://github.com/symfony/ux-autocomplete/commit/fabcb2eee14b9e84a45b276711853a560b5d770c
- https://github.com/symfony/ux-autocomplete/security/advisories/GHSA-4cpv-669c-r79x
- https://symfony.com/bundles/ux-autocomplete/current/index.html#usage-in-a-form-with-ajax
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/ux-autocomplete/CVE-2023-41336.yaml
- https://github.com/symfony/ux-autocomplete/commit/fabcb2eee14b9e84a45b276711853a560b5d770c
- https://github.com/symfony/ux-autocomplete/security/advisories/GHSA-4cpv-669c-r79x
- https://symfony.com/bundles/ux-autocomplete/current/index.html#usage-in-a-form-with-ajax
Get alerted when CVE-2023-41336 or the next vulnerability affects your stack