What’s Vulnerable › Vulnerabilities
CVE-2023-41339: Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-918
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The WMS specification defines an ``sld=<url>`` parameter for GetMap, GetLegendGraphic and GetFeatureInfo operations for user supplied "dynamic styling". Enabling the use of dynamic styles, without also configuring URL checks, provides the opportunity for Service Side Request Forgery. This vulnerability can be used to steal user NetNTLMv2 hashes which could be relayed or cracked externally to gain further access. This vulnerability has been patched in versions 2.22.5 and 2.23.2.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.22.5; from 2.23.0 before 2.23.2 — fixed in 2.22.5, 2.23.2
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.22.5, 2.23.2. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/releases/tag/2.22.5
- https://github.com/geoserver/geoserver/releases/tag/2.23.2
- https://github.com/geoserver/geoserver/security/advisories/GHSA-cqpc-x2c6-2gmf
- https://github.com/geoserver/geoserver/releases/tag/2.22.5
- https://github.com/geoserver/geoserver/releases/tag/2.23.2
- https://github.com/geoserver/geoserver/security/advisories/GHSA-cqpc-x2c6-2gmf
Get alerted when CVE-2023-41339 or the next vulnerability affects your stack