What’s Vulnerable › Vulnerabilities
CVE-2023-41362
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-29 · updated 2026-06-17
- Weakness: CWE-94
Description
MyBB before 1.8.36 allows Code Injection by users with certain high privileges. Templates in Admin CP intentionally use eval, and there was some validation of the input to eval, but type juggling interfered with this when using PCRE within PHP.
Affected products
- mybb: before 1.8.36 — fixed in 1.8.36
How to fix
Upgrade to a fixed version: mybb 1.8.36. Check the vendor advisory for mitigations.
References
- https://blog.sorcery.ie/posts/mybb_acp_rce/
- https://github.com/mybb/mybb/commit/a43a6f22944e769a6eabc58c39e7bc18c1cab4ca.patch
- https://github.com/mybb/mybb/security/advisories/GHSA-pr74-wvp3-q6f5
- https://mybb.com/versions/1.8.36/
- https://blog.sorcery.ie/posts/mybb_acp_rce/
- https://github.com/mybb/mybb/commit/a43a6f22944e769a6eabc58c39e7bc18c1cab4ca.patch
- https://github.com/mybb/mybb/security/advisories/GHSA-pr74-wvp3-q6f5
- https://mybb.com/versions/1.8.36/
Get alerted when CVE-2023-41362 or the next vulnerability affects your stack